p PatchFirst

CVE-2005-0638

CVE-2005-0638

This page contains facts from public vulnerability sources. Check the original advisory before updating.

xloadimage before 4.1-r2, and xli before 1.17, allows attackers to execute arbitrary commands via shell metacharacters in filenames for compressed images, which are not properly quoted when calling the gunzip command.

EPSS 3.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • xli Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.17.0-18

    Update to 1.17.0-18

  • xli Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.17.0-18

    Update to 1.17.0-18

  • xli Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.17.0-18

    Update to 1.17.0-18

  • xloadimage Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.1-14.1

    Update to 4.1-14.1

  • xloadimage Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.1-14.1

    Update to 4.1-14.1

  • xloadimage Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.1-14.1

    Update to 4.1-14.1

Original sources

Check your server →