p PatchFirst

CVE-2005-1194

CVE-2005-1194

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Stack-based buffer overflow in the ieee_putascii function for nasm 0.98 and earlier allows attackers to execute arbitrary code via a crafted asm file, a different vulnerability than CVE-2004-1287.

EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • nasm Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.98.38-1.2

    Update to 0.98.38-1.2

  • nasm Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.98.38-1.2

    Update to 0.98.38-1.2

  • nasm Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.98.38-1.2

    Update to 0.98.38-1.2

Original sources

Check your server →