p PatchFirst

CVE-2005-1344

CVE-2005-1344

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in htdigest in Apache 2.0.52 may allow attackers to execute arbitrary code via a long realm argument. NOTE: since htdigest is normally only locally accessible and not setuid or setgid, there are few attack vectors which would lead to an escalation of privileges, unless htdigest is executed from a CGI program. Therefore this may not be a vulnerability.

EPSS 29.1% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.54-3

    Update to 2.0.54-3

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.54-3

    Update to 2.0.54-3

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.54-3

    Update to 2.0.54-3

Original sources

Check your server →