p PatchFirst

CVE-2005-2040

CVE-2005-2040

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple buffer overflows in the getterminaltype function in telnetd for Heimdal before 0.6.5 may allow remote attackers to execute arbitrary code, a different vulnerability than CVE-2005-0468 and CVE-2005-0469.

EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • heimdal Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.6.3-11

    Update to 0.6.3-11

  • heimdal Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.6.3-11

    Update to 0.6.3-11

  • heimdal Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.6.3-11

    Update to 0.6.3-11

Original sources

Check your server →