p PatchFirst

CVE-2005-2700

CVE-2005-2700

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

ssl_engine_kernel.c in mod_ssl before 2.8.24, when using "SSLVerifyClient optional" in the global virtual host configuration, does not properly enforce "SSLVerifyClient require" in a per-location context, which allows remote attackers to bypass intended access restrictions.

EPSS 30.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.54-5

    Update to 2.0.54-5

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.54-5

    Update to 2.0.54-5

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.54-5

    Update to 2.0.54-5

Original sources

Check your server →