CVE-2005-3300
CVE-2005-3300
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The register_globals emulation layer in grab_globals.php for phpMyAdmin before 2.6.4-pl3 does not perform safety checks on values in the _FILES array for uploaded files, which allows remote attackers to include arbitrary files by using direct requests to library scripts that do not use grab_globals.php, then modifying certain configuration values for the theme.
EPSS 2.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
phpmyadmin Debian:12
- Affected ranges
- ECOSYSTEM: < 4:2.6.4-pl3-1
Update to 4:2.6.4-pl3-1
phpmyadmin Debian:13
- Affected ranges
- ECOSYSTEM: < 4:2.6.4-pl3-1
Update to 4:2.6.4-pl3-1
phpmyadmin Debian:14
- Affected ranges
- ECOSYSTEM: < 4:2.6.4-pl3-1
Update to 4:2.6.4-pl3-1
Original sources
- http://www.novell.com/linux/security/advisories/2005_28_sr.html
- http://www.novell.com/linux/security/advisories/2005_66_phpmyadmin.html
- http://secunia.com/advisories/17607
- http://archives.neohapsis.com/archives/fulldisclosure/2005-10/0478.
- http://secunia.com/advisories/17559
- http://www.hardened-php.net/advisory_162005.73.html
- http://marc.info/?l=bugtraq&m=113017591414699&w=2
- https://exchange.xforce.ibmcloud.com/vulnerabilities/22835
- http://www.debian.org/security/2005/dsa-880
- http://secunia.com/advisories/17337
- http://www.securityfocus.com/bid/15169
- http://www.gentoo.org/security/en/glsa/glsa-200510-21.xml
- http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-5
- http://secunia.com/advisories/17289/
- http://securitytracker.com/id?1015091
- https://nvd.nist.gov/vuln/detail/CVE-2005-3300