p PatchFirst

CVE-2005-3357

CVE-2005-3357

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

mod_ssl in Apache 2.0 up to 2.0.55, when configured with an SSL vhost with access control and a custom error 400 error page, allows remote attackers to cause a denial of service (application crash) via a non-SSL request to an SSL port, which triggers a NULL pointer dereference.

EPSS 24.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.55-4

    Update to 2.0.55-4

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.55-4

    Update to 2.0.55-4

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.55-4

    Update to 2.0.55-4

Original sources

Check your server →