CVE-2006-1711
CVE-2006-1711
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Plone 2.0.5, 2.1.2, and 2.5-beta1 does not restrict access to the (1) changeMemberPortrait, (2) deletePersonalPortrait, and (3) testCurrentPassword methods, which allows remote attackers to modify portraits.
EPSS 4.0% · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
plone PyPI
- Affected ranges
- ECOSYSTEM: < 2.0.6
Update to 2.0.6
plone PyPI
- Affected ranges
- ECOSYSTEM: ≥ 2.1.0, ≤ 2.1.2
No fix published
plone PyPI
- Versions
- 2.5-beta1
No fix published
plone PyPI
- Versions
- 2.5-beta1
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2a1
- 3.2rc1
- 3.3
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3b1
- 3.3rc1
- 3.3rc2
- 3.3rc3
- 3.3rc4
- 3.3rc5
- 4.0
- 4.0.1
- 4.0.10
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.0a1
- 4.0a2
- 4.0a3
- 4.0a4
- 4.0a5
- 4.0b1
- 4.0b2
- 4.0b3
- 4.0b4
- 4.0b5
- 4.0rc1
- 4.1
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1a1
- 4.1a2
- 4.1a3
- 4.1b1
- 4.1b2
- 4.1rc2
- 4.1rc3
- 4.2
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2a1
- 4.2a2
- 4.2b1
- 4.2b2
- 4.2rc1
- 4.2rc2
- 4.3
- 4.3.1
- 4.3.10
- 4.3.11
- 4.3.12
- 4.3.13
- 4.3.14
- 4.3.15
- 4.3.16
- 4.3.17
- 4.3.18
- 4.3.19
- 4.3.2
- 4.3.20
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- 4.3a1
- 4.3a2
- 4.3b1
- 4.3b2
- 4.3rc1
- 5.0
- 5.0.1
- 5.0.10
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.0.7
- 5.0.8
- 5.0.9
- 5.0a1
- 5.0a2
- 5.0a3
- 5.0b1
- 5.0b2
- 5.0b3
- 5.0b4
- 5.0rc1
- 5.0rc2
- 5.0rc3
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.3
- 5.1.4
- 5.1.5
- 5.1.6
- 5.1.7
- 5.1a1
- 5.1a2
- 5.1b1
- 5.1b2
- 5.1b3
- 5.1b4
- 5.1rc1
- 5.1rc2
- 5.2.0
- 5.2.1
- 5.2.10
- 5.2.11
- 5.2.12
- 5.2.13
- 5.2.14
- 5.2.15
- 5.2.2
- 5.2.3
- 5.2.4
- 5.2.5
- 5.2.6
- 5.2.7
- 5.2.8
- 5.2.9
- 5.2a1
- 5.2a2
- 5.2b1
- 5.2rc1
- 5.2rc2
- 5.2rc3
- 5.2rc4
- 5.2rc5
- 6.0.0
- 6.0.0a1
- 6.0.0a2
- 6.0.0a3
- 6.0.0a4
- 6.0.0a5
- 6.0.0a6
- 6.0.0b1
- 6.0.0b2
- 6.0.0b3
- 6.0.0rc1
- 6.0.0rc2
- 6.0.1
- 6.0.10
- 6.0.11
- 6.0.12
- 6.0.13
- 6.0.14
- 6.0.15
- 6.0.15rc1
- 6.0.15rc2
- 6.0.2
- 6.0.3
- 6.0.4
- 6.0.5
- 6.0.6
- 6.0.7
- 6.0.8
- 6.0.9
- 6.1.0
- 6.1.0a1
- 6.1.0a2
- 6.1.0a3
- 6.1.0a4
- 6.1.0a5
- 6.1.0b1
- 6.1.0b2
- 6.1.0rc1
- 6.1.1
- 6.1.1rc1
- 6.1.1rc2
- 6.1.2
- 6.1.3
- 6.1.4
- 6.1.5
- 6.2.0
- 6.2.0a1
- 6.2.0rc1
- 6.2.0rc2
- 6.2.1
- Affected ranges
- ECOSYSTEM: < 2.0.6 ∪ ≥ 2.1.0
Update to 2.0.6
Original sources
- http://dev.plone.org/plone/ticket/5432
- http://secunia.com/advisories/19633
- http://www.securityfocus.com/bid/17484
- http://www.debian.org/security/2006/dsa-1032
- http://secunia.com/advisories/19640
- http://www.vupen.com/english/advisories/2006/1340
- https://svn.plone.org/svn/plone/PloneHotfix20060410/trunk/README.txt
- https://exchange.xforce.ibmcloud.com/vulnerabilities/25781
- https://nvd.nist.gov/vuln/detail/CVE-2006-1711