p PatchFirst

CVE-2006-2450

CVE-2006-2450

This page contains facts from public vulnerability sources. Check the original advisory before updating.

auth.c in LibVNCServer 0.7.1 allows remote attackers to bypass authentication via a request in which the client specifies an insecure security type such as "Type 1 - None", which is accepted even if it is not offered by the server, a different issue than CVE-2006-2369.

EPSS 4.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libvncserver Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.8.2-1

    Update to 0.8.2-1

  • libvncserver Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.8.2-1

    Update to 0.8.2-1

  • libvncserver Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.8.2-1

    Update to 0.8.2-1

Original sources

Check your server →