p PatchFirst

CVE-2006-3082

CVE-2006-3082

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

parse-packet.c in GnuPG (gpg) 1.4.3 and 1.9.20, and earlier versions, allows remote attackers to cause a denial of service (gpg crash) and possibly overwrite memory via a message packet with a large length (long user ID string), which could lead to an integer overflow, as demonstrated using the --no-armor option.

EPSS 7.3% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnupg2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.9.20-1.1

    Update to 1.9.20-1.1

  • gnupg2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.20-1.1

    Update to 1.9.20-1.1

  • gnupg2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.20-1.1

    Update to 1.9.20-1.1

Original sources

Check your server →