p PatchFirst

CVE-2006-4112

CVE-2006-4112

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute arbitrary Ruby code via a URL that is not properly handled in the routing code, which leads to a denial of service (application hang) or "data loss," a different vulnerability than CVE-2006-4111.

EPSS 3.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.1.6-1

    Update to 1.1.6-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.1.6-1

    Update to 1.1.6-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.1.6-1

    Update to 1.1.6-1

Original sources

Check your server →