p PatchFirst

CVE-2006-5466

CVE-2006-5466

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Heap-based buffer overflow in the showQueryPackage function in librpm in RPM Package Manager 4.4.8, when the LANG environment variable is set to ru_RU.UTF-8, might allow user-assisted attackers to execute arbitrary code via crafted RPM packages.

EPSS 3.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rpm Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.4.1-11

    Update to 4.4.1-11

  • rpm Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.4.1-11

    Update to 4.4.1-11

  • rpm Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.4.1-11

    Update to 4.4.1-11

Original sources

Check your server →