p PatchFirst

CVE-2006-6235

CVE-2006-6235

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

EPSS 5.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnupg2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.0-5.2

    Update to 2.0.0-5.2

  • gnupg2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.0-5.2

    Update to 2.0.0-5.2

  • gnupg2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.0-5.2

    Update to 2.0.0-5.2

Original sources

Check your server →