p PatchFirst

CVE-2007-1001

CVE-2007-1001

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple integer overflows in the (1) createwbmp and (2) readwbmp functions in wbmp.c in the GD library (libgd) in PHP 4.0.0 through 4.4.6 and 5.0.0 through 5.2.1 allow context-dependent attackers to execute arbitrary code via Wireless Bitmap (WBMP) images with large width or height values.

EPSS 8.3% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libgd2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.33-1

    Update to 2.0.33-1

  • libgd2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.33-1

    Update to 2.0.33-1

  • libgd2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.33-1

    Update to 2.0.33-1

Original sources

Check your server →