p PatchFirst

CVE-2007-1049

CVE-2007-1049

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the wp_explain_nonce function in the nonce AYS functionality (wp-includes/functions.php) for WordPress 2.0 before 2.0.9 and 2.1 before 2.1.1 allows remote attackers to inject arbitrary web script or HTML via the file parameter to wp-admin/templates.php, and possibly other vectors involving the action variable.

EPSS 6.5% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.1.1-1

    Update to 2.1.1-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.1.1-1

    Update to 2.1.1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.1.1-1

    Update to 2.1.1-1

Original sources

Check your server →