p PatchFirst

CVE-2007-1054

CVE-2007-1054

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the AJAX features in index.php in MediaWiki 1.6.x through 1.9.2, when $wgUseAjax is enabled, allows remote attackers to inject arbitrary web script or HTML via a UTF-7 encoded value of the rs parameter, which is processed by Internet Explorer.

EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.7.1-9

    Update to 1.7.1-9

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.7.1-9

    Update to 1.7.1-9

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.7.1-9

    Update to 1.7.1-9

Original sources

Check your server →