p PatchFirst

CVE-2007-1216

CVE-2007-1216

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Double free vulnerability in the GSS-API library (lib/gssapi/krb5/k5unseal.c), as used by the Kerberos administration daemon (kadmind) in MIT krb5 before 1.6.1, when used with the authentication method provided by the RPCSEC_GSS RPC library, allows remote authenticated users to execute arbitrary code and modify the Kerberos key database via a message with an "an invalid direction encoding".

EPSS 9.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • krb5 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.4-8

    Update to 1.4.4-8

  • krb5 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.4-8

    Update to 1.4.4-8

  • krb5 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.4-8

    Update to 1.4.4-8

Original sources

Check your server →