p PatchFirst

CVE-2007-1897

CVE-2007-1897

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SQL injection vulnerability in xmlrpc (xmlrpc.php) in WordPress 2.1.2, and probably earlier, allows remote authenticated users to execute arbitrary SQL commands via a string parameter value in an XML RPC mt.setPostCategories method call, related to the post_id variable.

EPSS 7.2% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.1.3-1

    Update to 2.1.3-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.1.3-1

    Update to 2.1.3-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.1.3-1

    Update to 2.1.3-1

Original sources

Check your server →