p PatchFirst

CVE-2007-3476

CVE-2007-3476

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Array index error in gd_gif_in.c in the GD Graphics Library (libgd) before 2.0.35 allows user-assisted remote attackers to cause a denial of service (crash and heap corruption) via large color index values in crafted image data, which results in a segmentation fault.

EPSS 2.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libgd2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.35.dfsg-1

    Update to 2.0.35.dfsg-1

  • libgd2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.35.dfsg-1

    Update to 2.0.35.dfsg-1

  • libgd2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.35.dfsg-1

    Update to 2.0.35.dfsg-1

  • libwmf Debian:12

    Versions
    • 0.2.12-5.1
    • 0.2.12-5.2
    • 0.2.13-1
    • 0.2.13-1.1
    • 0.2.13-2
    • 0.2.14-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libwmf Debian:13

    Versions
    • 0.2.13-1.1
    • 0.2.13-2
    • 0.2.14-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libwmf Debian:14

    Versions
    • 0.2.13-1.1
    • 0.2.13-2
    • 0.2.14-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • racket Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.0.2-1

    Update to 5.0.2-1

  • racket Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.0.2-1

    Update to 5.0.2-1

  • racket Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.0.2-1

    Update to 5.0.2-1

Original sources

Check your server →