p PatchFirst

CVE-2007-3564

CVE-2007-3564

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libcurl 7.14.0 through 7.16.3, when built with GnuTLS support, does not check SSL/TLS certificate expiration or activation dates, which allows remote attackers to bypass certain access restrictions.

EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.16.4-1

    Update to 7.16.4-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.16.4-1

    Update to 7.16.4-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.16.4-1

    Update to 7.16.4-1

Original sources

Check your server →