p PatchFirst

CVE-2007-3999

CVE-2007-3999

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Stack-based buffer overflow in the svcauth_gss_validate function in lib/rpc/svc_auth_gss.c in the RPCSEC_GSS RPC library (librpcsecgss) in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and some third-party applications that use krb5, allows remote attackers to cause a denial of service (daemon crash) and probably execute arbitrary code via a long string in an RPC message.

EPSS 10.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • krb5 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.dfsg.1-7

    Update to 1.6.dfsg.1-7

  • krb5 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.dfsg.1-7

    Update to 1.6.dfsg.1-7

  • krb5 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.dfsg.1-7

    Update to 1.6.dfsg.1-7

Original sources

Check your server →