p PatchFirst

CVE-2007-4465

CVE-2007-4465

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Cross-site scripting (XSS) vulnerability in mod_autoindex.c in the Apache HTTP Server before 2.2.6, when the charset on a server-generated page is not defined, allows remote attackers to inject arbitrary web script or HTML via the P parameter using the UTF-7 charset. NOTE: it could be argued that this issue is due to a design limitation of browsers that attempt to perform automatic content type detection.

CVSS 6.1 · Medium · EPSS 26.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.6-1

    Update to 2.2.6-1

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.6-1

    Update to 2.2.6-1

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.6-1

    Update to 2.2.6-1

Original sources

Check your server →