p PatchFirst

CVE-2007-4743

CVE-2007-4743

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

EPSS 4.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • krb5 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.dfsg.1-7

    Update to 1.6.dfsg.1-7

  • krb5 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.dfsg.1-7

    Update to 1.6.dfsg.1-7

  • krb5 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.dfsg.1-7

    Update to 1.6.dfsg.1-7

Original sources

Check your server →