p PatchFirst

CVE-2007-4840

CVE-2007-4840

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PHP 5.2.4 and earlier allows context-dependent attackers to cause a denial of service (application crash) via (1) a long string in the out_charset parameter to the iconv function; or a long string in the charset parameter to the (2) iconv_mime_decode_headers, (3) iconv_mime_decode, or (4) iconv_strlen function. NOTE: this might not be a vulnerability in most web server environments that support multiple threads, unless these issues can be demonstrated for code execution.

EPSS 3.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.7-1

    Update to 2.7-1

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.7-1

    Update to 2.7-1

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.7-1

    Update to 2.7-1

Original sources

Check your server →