p PatchFirst

CVE-2007-5741

CVE-2007-5741

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Plone 2.5 through 2.5.4 and 3.0 through 3.0.2 allows remote attackers to execute arbitrary Python code via network data containing pickled objects for the (1) statusmessages or (2) linkintegrity module, which the module unpickles and executes.

CVSS 9.8 · Critical · EPSS 2.2% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • plone PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 2.5, < 2.5.5

    Update to 2.5.5

  • plone PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 3.0, < 3.0.3

    Update to 3.0.3

  • plone PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 2.5, < 2.5.5 ∪ ≥ 3.0, < 3.0.3

    Update to 2.5.5; Update to 3.0.3

Original sources

Check your server →