p PatchFirst

CVE-2008-0983

CVE-2008-0983

This page contains facts from public vulnerability sources. Check the original advisory before updating.

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • lighttpd Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.18-2

    Update to 1.4.18-2

  • lighttpd Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.18-2

    Update to 1.4.18-2

  • lighttpd Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.18-2

    Update to 1.4.18-2

Original sources

Check your server →