p PatchFirst

CVE-2008-2939

CVE-2008-2939

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Cross-site scripting (XSS) vulnerability in proxy_ftp.c in the mod_proxy_ftp module in Apache 2.0.63 and earlier, and mod_proxy_ftp.c in the mod_proxy_ftp module in Apache 2.2.9 and earlier 2.2 versions, allows remote attackers to inject arbitrary web script or HTML via a wildcard in the last directory component in the pathname in an FTP URI.

EPSS 39.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.9-7

    Update to 2.2.9-7

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.9-7

    Update to 2.2.9-7

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.9-7

    Update to 2.2.9-7

Original sources

Check your server →