p PatchFirst

CVE-2008-3639

CVE-2008-3639

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Heap-based buffer overflow in the read_rle16 function in imagetops in CUPS before 1.3.9 allows remote attackers to execute arbitrary code via an SGI image with malformed Run Length Encoded (RLE) data containing a small image and a large row count.

EPSS 4.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • cups Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.8-1lenny2

    Update to 1.3.8-1lenny2

  • cups Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.8-1lenny2

    Update to 1.3.8-1lenny2

  • cups Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.8-1lenny2

    Update to 1.3.8-1lenny2

Original sources

Check your server →