p PatchFirst

CVE-2008-4094

CVE-2008-4094

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.1.0-1

    Update to 2.1.0-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.1.0-1

    Update to 2.1.0-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.1.0-1

    Update to 2.1.0-1

Original sources

Check your server →