p PatchFirst

CVE-2008-4106

CVE-2008-4106

This page contains facts from public vulnerability sources. Check the original advisory before updating.

WordPress before 2.6.2 does not properly handle MySQL warnings about insertion of username strings that exceed the maximum column width of the user_login column, and does not properly handle space characters when comparing usernames, which allows remote attackers to change an arbitrary user's password to a random value by registering a similar username and then requesting a password reset, related to a "SQL column truncation vulnerability." NOTE: the attacker can discover the random password by also exploiting CVE-2008-4107.

EPSS 5.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.5.1-8

    Update to 2.5.1-8

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.5.1-8

    Update to 2.5.1-8

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.5.1-8

    Update to 2.5.1-8

Original sources

Check your server →