p PatchFirst

CVE-2008-4316

CVE-2008-4316

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple integer overflows in glib/gbase64.c in GLib before 2.20 allow context-dependent attackers to execute arbitrary code via a long string that is converted either (1) from or (2) to a base64 representation.

EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glib2.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.20.0-1

    Update to 2.20.0-1

  • glib2.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.20.0-1

    Update to 2.20.0-1

  • glib2.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.20.0-1

    Update to 2.20.0-1

Original sources

Check your server →