p PatchFirst

CVE-2008-4558

CVE-2008-4558

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Array index error in VLC media player 0.9.2 allows remote attackers to overwrite arbitrary memory and execute arbitrary code via an XSPF playlist file with a negative identifier tag, which passes a signed comparison.

EPSS 8.5% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • vlc Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.3-1

    Update to 0.9.3-1

  • vlc Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.3-1

    Update to 0.9.3-1

  • vlc Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.3-1

    Update to 0.9.3-1

Original sources

Check your server →