CVE-2008-5587
CVE-2008-5587
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.
EPSS 12.9% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
phppgadmin Debian:13
- Affected ranges
- ECOSYSTEM: < 4.2.1-1.1
Update to 4.2.1-1.1
phppgadmin Debian:14
- Affected ranges
- ECOSYSTEM: < 4.2.1-1.1
Update to 4.2.1-1.1
Original sources
- http://lists.opensuse.org/opensuse-updates/2012-04/msg00033.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/47140
- https://www.exploit-db.com/exploits/7363
- http://secunia.com/advisories/33014
- http://www.securityfocus.com/bid/32670
- http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00002.html
- http://securityreason.com/securityalert/4737
- http://secunia.com/advisories/33263
- http://www.debian.org/security/2008/dsa-1693
- https://nvd.nist.gov/vuln/detail/CVE-2008-5587