CVE-2008-7220
CVE-2008-7220
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Unspecified vulnerability in Prototype JavaScript framework (prototypejs) before 1.6.0.2 allows attackers to make "cross-site ajax requests" via unknown vectors.
EPSS 13.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
asterisk Debian:14
- Versions
- 0.1.11-3
- 0.1.11-3woody1
- 1:1.0.5-2
- 1:1.0.5-4
- 1:1.0.6-1
- 1:1.0.6-2
- 1:1.0.7-1
- 1:1.0.7.dfsg.1-1
- 1:1.0.7.dfsg.1-2
- 1:1.0.7.dfsg.1-2sarge1
- 1:1.0.7.dfsg.1-2sarge2
- 1:1.0.7.dfsg.1-2sarge3
- 1:1.0.7.dfsg.1-2sarge4
- 1:1.0.7.dfsg.1-2sarge5
- 1:1.0.7.dfsg.1-2sarge6
- 1:1.0.9.dfsg-1
- 1:1.0.9.dfsg-3
- 1:1.0.9.dfsg-4
- 1:1.0.9.dfsg-5
- 1:1.0.9.dfsg-6
- 1:1.2.0-beta1.dfsg-1
- 1:1.2.0-beta2.dfsg-1
- 1:1.2.0-beta2.dfsg-2
- 1:1.2.0-beta2.dfsg-3
- 1:1.2.0-rc1.dfsg-1
- 1:1.2.0-rc2.dfsg-1
- 1:1.2.0.dfsg-1
- 1:1.2.0.dfsg-2
- 1:1.2.0.dfsg-3
- 1:1.2.0.dfsg-4
- 1:1.2.0.dfsg-5
- 1:1.2.0.dfsg-6
- 1:1.2.1.dfsg-1
- 1:1.2.1.dfsg-2
- 1:1.2.1.dfsg-3
- 1:1.2.10.dfsg-1
- 1:1.2.10.dfsg-1bpo1
- 1:1.2.10.dfsg-2
- 1:1.2.10.dfsg-3
- 1:1.2.11.dfsg-1
- 1:1.2.12.1.dfsg-1
- 1:1.2.13~dfsg-1
- 1:1.2.13~dfsg-2
- 1:1.2.13~dfsg-2etch1
- 1:1.2.13~dfsg-2etch2
- 1:1.2.13~dfsg-2etch3
- 1:1.2.13~dfsg-2etch4
- 1:1.2.14~dfsg-1
- 1:1.2.14~dfsg-2
- 1:1.2.14~dfsg-3
- 1:1.2.14~dfsg-4
- 1:1.2.15~dfsg-1
- 1:1.2.16~dfsg-1
- 1:1.2.17~dfsg-1
- 1:1.2.4.dfsg-1
- 1:1.2.4.dfsg-2
- 1:1.2.4.dfsg-3
- 1:1.2.4.dfsg-4
- 1:1.2.4.dfsg-5
- 1:1.2.4.dfsg-6
- 1:1.2.4.dfsg-6+b1
- 1:1.2.4.dfsg-7
- 1:1.2.7.1.dfsg-1
- 1:1.2.7.1.dfsg-2
- 1:1.2.7.1.dfsg-3
- 1:1.2.9.1.dfsg-1
- 1:1.4.10~dfsg-1
- 1:1.4.11~dfsg-1
- 1:1.4.11~dfsg-2
- 1:1.4.11~dfsg-3
- 1:1.4.11~dfsg-4
- 1:1.4.13~dfsg-1
- 1:1.4.15~dfsg-1
- 1:1.4.16.2~dfsg-1
- 1:1.4.16.2~dfsg-2
- 1:1.4.17~dfsg-1
- 1:1.4.17~dfsg-2
- 1:1.4.18.1~dfsg-1
- 1:1.4.18~dfsg-1
- 1:1.4.19.1~dfsg-1
- 1:1.4.20~dfsg-1
- 1:1.4.21.1~dfsg-1
- 1:1.4.21.2~dfsg-1
- 1:1.4.21.2~dfsg-2
- 1:1.4.21.2~dfsg-3
- 1:1.4.21.2~dfsg-3+lenny1
- 1:1.4.21.2~dfsg-3+lenny2
- 1:1.4.21.2~dfsg-3+lenny2.1
- 1:1.4.21.2~dfsg-3+lenny3
- 1:1.4.21.2~dfsg-3+lenny5
- 1:1.4.21.2~dfsg-3+lenny6
- 1:1.4.21.2~dfsg-3.1
- 1:1.4.2~dfsg-1
- 1:1.4.2~dfsg-2
- 1:1.4.2~dfsg-3
- 1:1.4.2~dfsg-4
- 1:1.4.2~dfsg-5
- 1:1.4.3~dfsg-1
- 1:1.4.4~dfsg-1
- 1:1.4.4~dfsg-2
- 1:1.4.4~dfsg-3
- 1:1.4.5~dfsg-1
- 1:1.4.6~dfsg-1
- 1:1.4.8~dfsg-1
- 1:1.4.8~dfsg-2
- 1:1.4.9~dfsg-1
- 1:1.6.1.0~dfsg-1
- 1:1.6.1.0~dfsg~rc3-1
- 1:1.6.2.0~dfsg~beta3-1
- 1:1.6.2.0~dfsg~rc1-1
- Affected ranges
- ECOSYSTEM: < 1:1.6.2.0~rc3-1
Update to 1:1.6.2.0~rc3-1
exaile Debian:13
- Affected ranges
- ECOSYSTEM: < 0.2.14+debian-2.2
Update to 0.2.14+debian-2.2
exaile Debian:14
- Affected ranges
- ECOSYSTEM: < 0.2.14+debian-2.2
Update to 0.2.14+debian-2.2
jscropperui Debian:12
- Affected ranges
- ECOSYSTEM: < 1.2.1-1
Update to 1.2.1-1
jscropperui Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.1-1
Update to 1.2.1-1
jscropperui Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.1-1
Update to 1.2.1-1
libhtml-prototype-perl Debian:12
- Affected ranges
- ECOSYSTEM: < 1.48-3
Update to 1.48-3
libhtml-prototype-perl Debian:13
- Affected ranges
- ECOSYSTEM: < 1.48-3
Update to 1.48-3
libhtml-prototype-perl Debian:14
- Affected ranges
- ECOSYSTEM: < 1.48-3
Update to 1.48-3
prototypejs Debian:12
- Affected ranges
- ECOSYSTEM: < 1.6.0.2-1
Update to 1.6.0.2-1
prototypejs Debian:13
- Affected ranges
- ECOSYSTEM: < 1.6.0.2-1
Update to 1.6.0.2-1
prototypejs Debian:14
- Affected ranges
- ECOSYSTEM: < 1.6.0.2-1
Update to 1.6.0.2-1
scriptaculous Debian:12
- Affected ranges
- ECOSYSTEM: < 1.8.3-1
Update to 1.8.3-1
scriptaculous Debian:13
- Affected ranges
- ECOSYSTEM: < 1.8.3-1
Update to 1.8.3-1
scriptaculous Debian:14
- Affected ranges
- ECOSYSTEM: < 1.8.3-1
Update to 1.8.3-1
symfony Debian:12
- Affected ranges
- ECOSYSTEM: < 1.0.21-1.1
Update to 1.0.21-1.1
symfony Debian:13
- Affected ranges
- ECOSYSTEM: < 1.0.21-1.1
Update to 1.0.21-1.1
symfony Debian:14
- Affected ranges
- ECOSYSTEM: < 1.0.21-1.1
Update to 1.0.21-1.1
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 2.5.0-2
Update to 2.5.0-2
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 2.5.0-2
Update to 2.5.0-2
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 2.5.0-2
Update to 2.5.0-2
Original sources
- https://www.redhat.com/archives/fedora-package-announce/2009-November/msg00838.html
- http://secunia.com/advisories/37479
- http://osvdb.org/46312
- http://secunia.com/advisories/37677
- http://www.debian.org/security/2009/dsa-1952
- https://bugzilla.redhat.com/show_bug.cgi?id=523277
- http://github.com/sstephenson/prototype/blob/master/CHANGELOG
- https://bugzilla.redhat.com/show_bug.cgi?id=533137
- https://www.redhat.com/archives/fedora-package-announce/2009-November/msg00789.html
- http://www.openwall.com/lists/oss-security/2009/11/07/2
- https://seclists.org/bugtraq/2019/May/18
- http://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies.html
- http://seclists.org/fulldisclosure/2019/May/11
- http://seclists.org/fulldisclosure/2019/May/10
- http://seclists.org/fulldisclosure/2019/May/13
- https://lists.apache.org/thread.html/eff7280055fc717ea8129cd28a9dd57b8446d00b36260c1caee10b87%40%3Cnotifications.zookeeper.apache.org%3E
- https://lists.apache.org/thread.html/7ba863c5a4a0f1230cba2d11cf4de3a2eda3a42e8023d4990f564327%40%3Cdev.zookeeper.apache.org%3E
- https://lists.apache.org/thread.html/6d1b9a75a004dab42c81e8aa149d90e6fd26ce8cd6d71295e565e366%40%3Cissues.zookeeper.apache.org%3E
- https://lists.apache.org/thread.html/2ad48cd9d47edd0e677082eb869115809473a117e1e30b52fb511590%40%3Cissues.zookeeper.apache.org%3E
- https://lists.apache.org/thread.html/769fcc5f331b61c4d7ce16b807678e9a1799628d0146322e14aa24ed%40%3Cdev.zookeeper.apache.org%3E
- https://nvd.nist.gov/vuln/detail/CVE-2008-7220