p PatchFirst

CVE-2008-7248

CVE-2008-7248

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

EPSS 8.1% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.3-1

    Update to 2.2.3-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.3-1

    Update to 2.2.3-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.3-1

    Update to 2.2.3-1

Original sources

Check your server →