p PatchFirst

CVE-2009-0025

CVE-2009-0025

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

BIND 9.6.0, 9.5.1, 9.5.0, 9.4.3, and earlier does not properly check the return value from the OpenSSL DSA_verify function, which allows remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature, a similar vulnerability to CVE-2008-5077.

EPSS 6.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • bind9 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:9.5.1.dfsg.P1-1

    Update to 1:9.5.1.dfsg.P1-1

  • bind9 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:9.5.1.dfsg.P1-1

    Update to 1:9.5.1.dfsg.P1-1

  • bind9 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:9.5.1.dfsg.P1-1

    Update to 1:9.5.1.dfsg.P1-1

Original sources

Check your server →