p PatchFirst

CVE-2009-1180

CVE-2009-1180

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

The JBIG2 decoder in Xpdf 3.02pl2 and earlier, CUPS 1.3.9 and earlier, Poppler before 0.10.6, and other products allows remote attackers to execute arbitrary code via a crafted PDF file that triggers a free of invalid data.

EPSS 5.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • poppler Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.10.6-1

    Update to 0.10.6-1

  • poppler Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.10.6-1

    Update to 0.10.6-1

  • poppler Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.10.6-1

    Update to 0.10.6-1

  • xpdf Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.02-1.4+lenny1

    Update to 3.02-1.4+lenny1

  • xpdf Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.02-1.4+lenny1

    Update to 3.02-1.4+lenny1

  • xpdf Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.02-1.4+lenny1

    Update to 3.02-1.4+lenny1

Original sources

Check your server →