CVE-2009-1513
CVE-2009-1513
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer overflow in the PATinst function in src/load_pat.cpp in libmodplug before 0.8.7 allows user-assisted remote attackers to cause a denial of service and possibly execute arbitrary code via a long instrument name.
EPSS 4.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libmodplug Debian:12
- Affected ranges
- ECOSYSTEM: < 1:0.8.7-1
Update to 1:0.8.7-1
libmodplug Debian:13
- Affected ranges
- ECOSYSTEM: < 1:0.8.7-1
Update to 1:0.8.7-1
libmodplug Debian:14
- Affected ranges
- ECOSYSTEM: < 1:0.8.7-1
Update to 1:0.8.7-1
Original sources
- http://www.ubuntu.com/usn/USN-771-1
- http://secunia.com/advisories/35736
- http://secunia.com/advisories/34927
- http://www.debian.org/security/2009/dsa-1850
- http://www.securityfocus.com/bid/34747
- http://modplug-xmms.cvs.sourceforge.net/viewvc/modplug-xmms/libmodplug/src/load_pat.cpp?r1=1.3&r2=1.4
- http://secunia.com/advisories/36158
- http://sourceforge.net/tracker/?func=detail&aid=2777467&group_id=1275&atid=301275
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:128
- http://osvdb.org/54109
- http://secunia.com/advisories/35026
- http://www.openwall.com/lists/oss-security/2009/04/29/5
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=526084
- http://security.gentoo.org/glsa/glsa-200907-07.xml
- http://modplug-xmms.git.sourceforge.net/git/gitweb.cgi?p=modplug-xmms%3Ba=commitdiff%3Bh=c4ebb701be6ee9a296a44fdac5a20b7739ff0595
- http://sourceforge.net/project/shownotes.php?release_id=678622&group_id=1275
- http://www.vupen.com/english/advisories/2009/1200
- https://nvd.nist.gov/vuln/detail/CVE-2009-1513