p PatchFirst

CVE-2009-1720

CVE-2009-1720

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors that trigger heap-based buffer overflows, related to (1) the Imf::PreviewImage::PreviewImage function and (2) compressor constructors. NOTE: some of these details are obtained from third party information.

EPSS 6.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openexr Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.1-4.1

    Update to 1.6.1-4.1

  • openexr Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.1-4.1

    Update to 1.6.1-4.1

  • openexr Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.1-4.1

    Update to 1.6.1-4.1

Original sources

Check your server →