p PatchFirst

CVE-2009-2334

CVE-2009-2334

This page contains facts from public vulnerability sources. Check the original advisory before updating.

wp-admin/admin.php in WordPress and WordPress MU before 2.8.1 does not require administrative authentication to access the configuration of a plugin, which allows remote attackers to specify a configuration file in the page parameter to obtain sensitive information or modify this file, as demonstrated by the (1) collapsing-archives/options.txt, (2) akismet/readme.txt, (3) related-ways-to-take-action/options.php, (4) wp-security-scan/securityscan.php, and (5) wp-ids/ids-admin.php files. NOTE: this can be leveraged for cross-site scripting (XSS) and denial of service.

EPSS 6.3% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.8.3-1

    Update to 2.8.3-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.8.3-1

    Update to 2.8.3-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.8.3-1

    Update to 2.8.3-1

Original sources

Check your server →