p PatchFirst

CVE-2009-2414

CVE-2009-2414

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Stack consumption vulnerability in libxml2 2.5.10, 2.6.16, 2.6.26, 2.6.27, and 2.6.32, and libxml 1.8.17, allows context-dependent attackers to cause a denial of service (application crash) via a large depth of element declarations in a DTD, related to a function recursion, as demonstrated by the Codenomicon XML fuzzing framework.

EPSS 3.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.7.3.dfsg-2.1

    Update to 2.7.3.dfsg-2.1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.7.3.dfsg-2.1

    Update to 2.7.3.dfsg-2.1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.7.3.dfsg-2.1

    Update to 2.7.3.dfsg-2.1

Original sources

Check your server →