p PatchFirst

CVE-2009-2416

CVE-2009-2416

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple use-after-free vulnerabilities in libxml2 2.5.10, 2.6.16, 2.6.26, 2.6.27, and 2.6.32, and libxml 1.8.17, allow context-dependent attackers to cause a denial of service (application crash) via crafted (1) Notation or (2) Enumeration attribute types in an XML file, as demonstrated by the Codenomicon XML fuzzing framework.

CVSS 6.5 · Medium · EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.7.3.dfsg-2.1

    Update to 2.7.3.dfsg-2.1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.7.3.dfsg-2.1

    Update to 2.7.3.dfsg-2.1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.7.3.dfsg-2.1

    Update to 2.7.3.dfsg-2.1

Original sources

Check your server →