CVE-2009-2737
CVE-2009-2737
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
EPSS 2.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
roundup PyPI
- Versions
- 1.2.0
- Affected ranges
- ECOSYSTEM: ≥ 1.2, < 1.2.1
Update to 1.2.1
roundup PyPI
- Versions
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5.1
- 1.4.6
- Affected ranges
- ECOSYSTEM: ≥ 1.4, < 1.4.7
Update to 1.4.7
roundup PyPI
- Versions
- 1.2.0
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5.1
- 1.4.6
- Affected ranges
- ECOSYSTEM: ≥ 1.2, < 1.2.1 ∪ ≥ 1.4, < 1.4.7
Update to 1.2.1; Update to 1.4.7
Original sources
- http://secunia.com/advisories/34192
- http://www.osvdb.org/56368
- https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00429.html
- https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00439.html
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=518768
- http://www.securityfocus.com/bid/34059
- http://issues.roundup-tracker.org/issue2550521
- https://bugzilla.redhat.com/show_bug.cgi?id=489355
- http://www.debian.org/security/2009/dsa-1754
- https://nvd.nist.gov/vuln/detail/CVE-2009-2737