p PatchFirst

CVE-2009-3009

CVE-2009-3009

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.3-1

    Update to 2.2.3-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.3-1

    Update to 2.2.3-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.3-1

    Update to 2.2.3-1

Original sources

Check your server →