p PatchFirst

CVE-2009-3026

CVE-2009-3026

This page contains facts from public vulnerability sources. Check the original advisory before updating.

protocols/jabber/auth.c in libpurple in Pidgin 2.6.0, and possibly other versions, does not follow the "require TLS/SSL" preference when connecting to older Jabber servers that do not follow the XMPP specification, which causes libpurple to connect to the server without the expected encryption and allows remote attackers to sniff sessions.

EPSS 1.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pidgin Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.6.1-1

    Update to 2.6.1-1

  • pidgin Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.6.1-1

    Update to 2.6.1-1

  • pidgin Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.6.1-1

    Update to 2.6.1-1

Original sources

Check your server →