p PatchFirst

CVE-2009-3605

CVE-2009-3605

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple integer overflows in Poppler 0.10.5 and earlier allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PDF file, related to (1) glib/poppler-page.cc; (2) ArthurOutputDev.cc, (3) CairoOutputDev.cc, (4) GfxState.cc, (5) JBIG2Stream.cc, (6) PSOutputDev.cc, and (7) SplashOutputDev.cc in poppler/; and (8) SplashBitmap.cc, (9) Splash.cc, and (10) SplashFTFont.cc in splash/. NOTE: this may overlap CVE-2009-0791.

EPSS 4.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • poppler Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.12.2-1

    Update to 0.12.2-1

  • poppler Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.12.2-1

    Update to 0.12.2-1

  • poppler Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.12.2-1

    Update to 0.12.2-1

Original sources

Check your server →