CVE-2009-3608
CVE-2009-3608
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
Integer overflow in the ObjectStream::ObjectStream function in XRef.cc in Xpdf 3.x before 3.02pl4 and Poppler before 0.12.1, as used in GPdf, kdegraphics KPDF, CUPS pdftops, and teTeX, might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.
EPSS 10.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
poppler Debian:12
- Affected ranges
- ECOSYSTEM: < 0.12.2-1
Update to 0.12.2-1
poppler Debian:13
- Affected ranges
- ECOSYSTEM: < 0.12.2-1
Update to 0.12.2-1
poppler Debian:14
- Affected ranges
- ECOSYSTEM: < 0.12.2-1
Update to 0.12.2-1
xpdf Debian:12
- Affected ranges
- ECOSYSTEM: < 3.02-2
Update to 3.02-2
xpdf Debian:13
- Affected ranges
- ECOSYSTEM: < 3.02-2
Update to 3.02-2
xpdf Debian:14
- Affected ranges
- ECOSYSTEM: < 3.02-2
Update to 3.02-2
ipe Ubuntu:16.04:LTS
- Versions
- 7.1.4-2.1
- 7.1.8-1
- 7.1.10-1
- 7.1.10-1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:18.04:LTS
- Versions
- 7.2.7-2
- 7.2.7-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:20.04:LTS
- Versions
- 7.2.9-1
- 7.2.13-2
- 7.2.13-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:22.04:LTS
- Versions
- 7.2.23+dfsg1-2
- 7.2.24+dfsg1-1
- 7.2.24+dfsg1-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:24.04:LTS
- Versions
- 7.2.27+dfsg1-2
- 7.2.28-2
- 7.2.28-2.1build2
- 7.2.28-2.1build3
- 7.2.28-2.1build4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:25.10
- Versions
- 7.2.30-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:26.10
- Versions
- 7.2.30-1build2
- 7.2.30-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:26.04:LTS
- Versions
- 7.2.30-1build1
- 7.2.30-1build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://secunia.com/advisories/39938
- https://rhn.redhat.com/errata/RHSA-2009-1504.html
- http://www.debian.org/security/2009/dsa-1941
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:287
- https://bugzilla.redhat.com/show_bug.cgi?id=526637
- http://www.openwall.com/lists/oss-security/2009/12/01/6
- http://secunia.com/advisories/37028
- http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035408.html
- https://www.redhat.com/archives/fedora-package-announce/2009-October/msg00750.html
- http://poppler.freedesktop.org/
- https://rhn.redhat.com/errata/RHSA-2009-1501.html
- http://secunia.com/advisories/37079
- http://lists.opensuse.org/opensuse-security-announce/2009-11/msg00004.html
- http://www.debian.org/security/2010/dsa-2028
- http://www.debian.org/security/2010/dsa-2050
- http://www.openwall.com/lists/oss-security/2009/12/01/1
- http://secunia.com/advisories/37159
- http://secunia.com/advisories/37054
- http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035340.html
- http://sunsolve.sun.com/search/document.do?assetkey=1-77-1021706.1-1
- https://www.redhat.com/archives/fedora-package-announce/2009-October/msg00784.html
- https://rhn.redhat.com/errata/RHSA-2009-1512.html
- http://secunia.com/advisories/37114
- https://nvd.nist.gov/vuln/detail/CVE-2009-3608