p PatchFirst

CVE-2009-3616

CVE-2009-3616

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple use-after-free vulnerabilities in vnc.c in the VNC server in QEMU 0.10.6 and earlier might allow guest OS users to execute arbitrary code on the host OS by establishing a connection from a VNC client and then (1) disconnecting during data transfer, (2) sending a message using incorrect integer data types, or (3) using the Fuzzy Screen Mode protocol, related to double free vulnerabilities.

CVSS 9.9 · Critical · EPSS 3.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • qemu Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.11.0-1

    Update to 0.11.0-1

  • qemu Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.11.0-1

    Update to 0.11.0-1

  • qemu Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.11.0-1

    Update to 0.11.0-1

Original sources

Check your server →