p PatchFirst

CVE-2009-4032

CVE-2009-4032

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple cross-site scripting (XSS) vulnerabilities in Cacti 0.8.7e allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) graph.php, (2) include/top_graph_header.php, (3) lib/html_form.php, and (4) lib/timespan_settings.php, as demonstrated by the (a) graph_end or (b) graph_start parameters to graph.php; (c) the date1 parameter in a tree action to graph_view.php; and the (d) page_refresh and (e) default_dual_pane_width parameters to graph_settings.php.

EPSS 5.7% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • cacti Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.8.7e-1.1

    Update to 0.8.7e-1.1

  • cacti Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.8.7e-1.1

    Update to 0.8.7e-1.1

  • cacti Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.8.7e-1.1

    Update to 0.8.7e-1.1

Original sources

Check your server →