p PatchFirst

CVE-2009-4212

CVE-2009-4212

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple integer underflows in the (1) AES and (2) RC4 decryption functionality in the crypto library in MIT Kerberos 5 (aka krb5) 1.3 through 1.6.3, and 1.7 before 1.7.1, allow remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code by providing ciphertext with a length that is too short to be valid.

EPSS 7.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • krb5 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.8+dfsg~alpha1-1

    Update to 1.8+dfsg~alpha1-1

  • krb5 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.8+dfsg~alpha1-1

    Update to 1.8+dfsg~alpha1-1

  • krb5 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.8+dfsg~alpha1-1

    Update to 1.8+dfsg~alpha1-1

Original sources

Check your server →